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Introduction 
The W8Antenna TEE/K2ZIA Analyzer (AA) is a general purpose antenna analyzer than can measure 
resonance for a given antenna system. While it is possible to perform measurements on any frequency 
segment between 1.0 and 30.0 MHz, the AA comes pre-configured for the 160 through 10 meter 
amateur radio bands. The AA measures the ratio of the forward and reflect wave (or voltage standing 
wave ratio, VSWR) across each frequency segment. A perfect (theoretical) match between the 
transmission line and the antenna impedance would be 1:1, although values under 2.0:1 are often 
considered acceptable. Because the VSWR of an antenna system varies with respect to frequency, the 
AA allows you to determine the range for each data scan.  
 
The AA does not require an external PC or laptop for its use. The scan data are temporarily saved in 
memory and may be subsequently displayed in either tabular or graphic plot format on the built-in TFT 
color display. If the user desires, they can save the most-recent plot to an onboard SD card. Scan data 
that are saved to an SD card may be exported via a USB connection to another computer. The exported 
data is stored and exported in a Comma Separated Variables format (CSV), which can be imported 
easily into a text editor or spreadsheet for further analysis.  
 
The AA can be powered by a 9V battery or a 120V-to-9V voltage adapter (e.g., “wall wart”). There are 
only two controls on the AA: 1) an on/off switch, and 2) the Select knob, which is actually a rotary 
encoder with a built-in switch. The on/off switch allows you to toggle between power sources. The 
single Select knob provides all of the functions necessary to control the unit. 
 

Main Menu 

The startup screen for the AA is shown in Figure 1. This first screen shows the main menu options  
Figure 1. Antenna Analyzer Startup Screen 



 
across the top of the display, with the Analysis menu option currently selected on power up. The current 
selection is always highlighted. Turning the Select knob clockwise (CW) advances the highlighted 
selection to the Results menu option. Another CW move of the Select knob highlights the File menu 
option. Another CW move causes the highlighted option to “wrap around” back to the Analysis menu 
option. Likewise, if you had the Analysis menu option highlighted and turned the Select knob counter 
clockwise (CCW), the File menu option would be highlighted. 
 
As a general rule, rotating the Select knob moves between menu items. In Figure 1, rotation results in 
movement to the left (CCW rotation) or right (CW rotation ), depending upon the direction of rotation. 
Other menus may be oriented in an up-down fashion (see Figure 2). In these cases, CW rotation moves 
the menu option towards the bottom of the display, while a CCW moves the option towards the top of 
the display. If the end points of a menu is reached but the same direction continued, the menu wraps 
around to the other end of the menu option list. 

Analysis 
The Select knob has a built-in switch. If you currently have the Analysis menu item shown in Figure 1 
selected and push on the Select knob, the display screen changes to show you a submenu. This 
submenu is shown in Figure 2. By default, activating a submenu always highlights the first item in the 
new submenu. The first submenu item in the Analysis submenu is New Scan, followed by other 
submenu items.  

 
Figure 2. The Analysis submenu. 
 



New Scan 

If you press the Select knob as shown in Figure 2, you will select the New Scan submenu option The 
display shows the bands covered by the AA . This is shown in Figure 3. The 40M band is highlighted in 
the Figure, which means you wish to run a scan on some segment of the 40M band. Once you have 
selected the band, press the encoder switch to set the start and end frequencies for the scan. 

Figure 3. The minimum VSWR for all scanned bands. 
 
Figure 4 shows the input screen for setting the scan parameters. The software knows the upper and 
lower frequencies for the 160-10M US bands.  You can change these if need be. If you are running a 
scan on a new 40M antenna, you might enter a frequency below the start of the 40M band (e.g., 6500) 

Figure 4. Inputting scan parameters. 
 



and an ending value above 7300, just in case the antenna is resonant outside the band. This would allow 
you to figure out whether the antenna is too long or too short. Press the encoder after the start and end 
values for the scan are entered. Once the ending frequency is entered, the scan starts immediately. 
 
There's a lot going on during a scan. The code divides the frequency spread into 100 equal segments. It 
then sets the DDS oscillator to that starting value and sends a signal to the antenna. The program takes 
75 sample readings at each of those 100 frequency intervals; 7500 samples in all. The resulting plot is 
based on these samples. An example can be seen in Figure 5. 

 
Figure 5. Sample plot. 
 
In Figure 5, you can see that we started the plot at 6.9MHz and ended it at 7.4MHz. The minimum 
VSWR is at 7.158333MHz with a value of 1.15. Note that if the SWR is above 3.0, the value is NOT 
plotted. It is possible, therefore, that a scan will plot no data for an antenna that has its resonant 
frequency far outside the parameters used for the scan. Press the encoder switch to return to the main 
menu. 
 
Also note that, if you want to save this scan, you should go to the Options menu and select Save Scan. 
(Saving a scan is explained below.) The reason for saving it now is because the data is held in memory 
only until the next scan is performed. When a new scan is started, the current scan data is lost. If you 
are tuning your antenna, you may want to save it so you can overlay this scan data with the data from a 
new scan after some adjustment to the antenna. 
 
Each time you run a scan for a band, its minimum value (e.g., 7.158333MHz) is saved in EEPROM so 
it can be retrieved later even if the unit is turned off. When power is again applied to the AA, the 



EEPROM data is read and ready for display. Note, however, that this means that previous minimum 
scan data is lost each time a new scan is run. This shouldn't be a burden, however, since you can save 
the data from each scan. Depending on the SD card you are using, you can save over 9,000 scans. 
 

Repeat 

Once you have viewed the data, press the Select knob again, which returns you to the main menu 
(Figure 1). If you re-select Analysis and rotate the Select knob CW, the menu selection moves to the 
next menu item (e.g., Repeat). The purpose of the Repeat option is to allow you to run a new scan, but 
using the same input parameters as the previous scan. That is, you can perform a new scan, but using 
the same starting and ending frequency. This is useful if you are making small adjustments to an 
antenna and repeatedly running scans for that antenna. The output, of course, will look similar to that 
shown in Figure 5. 
 

Frequency 

Frequency allows you to adjust the frequency and get a VSWR reading for that frequency. It's similar to 
a scan, but you enter a single frequency, and the code immediately measures the VSWR at that 
frequency. You can use the rotary encoder to adjust the frequency up or down and see the impact on the 
VSWR. This feature could be useful if you are fine tuning an antenna like a magnetic loop. 
 

Options 
The Options menu item activates a submenu that, for the most part, applies to actions taken 
immediately after a scan is performed. These options are presented in Figure 6. The first option in the  

 
Figure 6. The Options submenu. 
 



submenu is Save Scan. 
 

Save Scan 

This option allows you to save the most recent scan to the micro SD card that is housed on the back of 
the TFT display. The maximum usable size of the SD card is 2Mb, but that's more than enough for 
almost everyone. The SD card is read when power is applied to the AA. Part of the startup routine 
checks for the presence of the SD card and to see if it is initialized. If both conditions are true, the main 
menu is displayed. If either test fails, a message is given telling you that the SD card either is not in the 
slot or formatted correctly. 

The code automatically names and display the file name and saves the data from the most recent scan 
(which is being held in memory) to the SD card. When the data are stored on the SD card, a message is 
displayed telling you the data have been written to disk. 

 

View Plot 

This option lets you view a scan that has been previously stored on disk. Selecting this option requires 
you to select the scan you wish to view. The selection screen looks like Figure 7. You select the file by  

Figure 7. File selection for View Plot. 
 
rotating the encoder switch; CW to move down the list, CCW to move up the list. Once you select the 
file and press the encoder switch, the plot looks essentially the same as Figure 5. Note that the data is in 
comma separated variables (CSV) format, which allows the data to be viewed with other programs 
once exported to a PC via a USB cable. 
 

View Table 

The plot data may also be viewed in tabular form. The file selection process is the same as for View 
Plot. When the file has been selected, the data are displayed in tabular format, as shown in Figure 8. 



Figure 8. Plot data in tabular format. 
 
The displayed data is a compromise forced by the screen size. Fixed point notation is used for the 
display. For example, the first data point is 3.15  6.900. This means the VSWR is 3.15 at a frequency of 
6.900MHz. The next sample point is 3.14 6.905, which illustrates that the data are read across rows and 
then down columns. Looking closely at the data you can see the sample points are spread evenly across 
5KHz increments. You can scroll the display with the encoder.  
 
When you are done reviewing the data, press the encoder switch to return to the main menu. 
 

Overlay 

The overlay option allows you to select a previously-stored scan and overlay it onto the current scan 
that is stored in memory. When this option is activated, you need to select which file stored on the 
micro SD card you wish to overlay with the current scan. The file selection process is the same as the 
View Plot option discussed earlier. Once selected, the two plots are displayed. An example appears in  



Figure 9. Overlay scan plot. 
 
Figure 9. Overlaying makes it easy to see the impact of whatever changes you made to the antenna 
between the two scans. Pressing the encoder switch returns you to the main menu. 
 

Serial 

This option allows you to direct a file to your PC. Perhaps the simplest way to copy the file is to 
display it on the serial monitor, copy its contents, and save that as a text file. You can also just read the 
SD card file directly and then import it into a spreadsheet or graphics program as a CSV file.  The file 
selection process is the same as the View Plot instructions. 
 

Delete File 

This option lets you delete a file from the SD card. Our experience is that we generated about a dozen 
files in the process of experimenting with an antenna. Once we did that, we removed the SD card and 
used a card reader and copied the files to our PC in case we wanted to use them at a later date. We then 
replaced the SD card into its slot on the display and used this option to erase all of the files on the card.  
 
We did this not because we were running out of card space, but rather to “declutter” the SD card. Then 
the next time we were experimenting with an antenna, we knew that all scans pertained to the current 
antenna. Of course you can keep the data, but scrolling does get a little boring after a while. 



Selecting the file to be deleted is the same as selecting a file using View Plot. Once selected, you are 
asked to confirm that you wish to delete the file. Answering yes permanently erases the file from the 
SD card. Press the encoder switch to return to the main menu. 
 

View Mins 
This option allows you to view the minimum VSWRs that have been stored in EEPROM. When you 
select this option, the submenu shown in Figure 10 is presented. The All option is currently highlighted. 

Figure 10. The View Mins submenu. 
 
If you press the encoder switch, the display changes to that shown in Figure 11. Note that only the 80M 
band has scan data show. All of the rest have N/A on the right side of the display. This shows that no 
antenna scans have been performed on any band other than 80M. As you experiment with other bands, 
the minimum VSWR measured for each band is written to EEPROM. By writing it to EEPROM, the 
data is preserved even when power is removed. 
 
If you had selected the 80M option in Figure 10, the results would be as shown in Figure 12. Pressing 
the encoder switch returns you to the main menu. 
 
This concludes the Users Manual. 
 



Figure 11. Minimum VSWRs for all bands. 
 

Figure 21. Minimum VSWR for 80M. 
 


